Unable to load dynamic library '/usr/lib/php/20180731/swoole.so'

2022年7月21日

原因是 swoole 的优先级高于某些依赖库,导致加载 swoole 时,其他依赖库尚未加载。

解决方法是在 conf.d 下创建一个优先级较低的 .ini 文件,例如

cd /etc/php/7.3/apache2/conf.d

// 创建
sudo touch 30-swoole.ini

// 编辑
sudo vim 30-swoole.ini

// 内容是
extension=swoole.so

同时,cli 目录下也执行同样的操作。

最后,重启 apache 即可在 phpinfo() 中看到 swoole 模块。

小鑫

写写代码, 掉掉头发。

文章评论